[Cyberduck-trac] [Cyberduck] #1016: SFTP: Login Not Attempting Public Key Authentication

Cyberduck trac at trac.cyberduck.ch
Sun Feb 4 22:58:38 CET 2007

#1016: SFTP: Login Not Attempting Public Key Authentication
 Reporter:  ibrandt  |        Owner:  dkocher
     Type:  defect   |       Status:  new    
 Priority:  normal   |    Milestone:         
Component:  sftp     |      Version:  2.7.2  
 Severity:  normal   |   Resolution:         
 Keywords:           |  
Changes (by ibrandt):

  * severity:  major => normal


 If I create it as a bookmark and connect via that it works.  Still no luck
 from the standard connect dialog however.

 I am definitely checking off the 'Use Public Key Authentication' option.
 As confirmation after choosing it and selecting my private key the path to
 the key is displayed as a text field.  I've just tried making the
 selection of the option the first thing I enter into the dialog (it was
 the last thing I was doing) in hopes that entering a value after it
 ('Server' for example) would encourage the selection to "take", but it
 made no difference.

 I've got the trunk up and running in Xcode with the debugger attached.  I
 can reproduce the issue.  Aside from a Hello World tutorial I did over a
 year ago I'm totally green with Xcode and native Mac apps.  I do know Java
 well, and I have academic knowledge of Objective-C, so I might be able to
 root out the problem.  If you could recommend any particular breakpoints
 to start from that would speed things up a lot on my end.

 Lowering the severity to normal as there is now a known workaround.

Ticket URL: <http://trac.cyberduck.ch/ticket/1016#comment:2>
Cyberduck <http://cyberduck.ch>
FTP and SFTP Browser for Mac OS X.

More information about the Cyberduck-trac mailing list