[Cyberduck-trac] [Cyberduck] #1160: Unable to download files

Cyberduck trac at trac.cyberduck.ch
Thu Jul 12 12:19:04 CEST 2007

#1160: Unable to download files
 Reporter:  blind_io  |       Owner:  dkocher          
     Type:  defect    |      Status:  new              
 Priority:  highest   |   Milestone:                   
Component:  sftp      |     Version:  2.8b1            
 Severity:  critical  |    Keywords:  sftp upload error
 When logging on to a server using the SFTP protocol and downloading a
 file, the following exception is thrown and the download is aborted.

 I tried several different servers with the same result. Uploading works
 fine, and downloading from ordinary FTP servers works without problem.

 Exception in thread "Background" java.lang.IllegalArgumentException:
 invalid len argument
         at ch.ethz.ssh2.sftp.SFTPv3Client.read(Unknown Source)
         at ch.ethz.ssh2.io.SFTPInputStream.read(Unknown Source)
         at ch.cyberduck.core.io.ThrottledInputStream.read(Unknown Source)
         at ch.cyberduck.core.Path.transfer(Unknown Source)
         at ch.cyberduck.core.Path.download(Unknown Source)
         at ch.cyberduck.core.sftp.SFTPPath.download(Unknown Source)
         at ch.cyberduck.core.DownloadTransfer._transferImpl(Unknown
         at ch.cyberduck.core.Transfer.transfer(Unknown Source)
         at ch.cyberduck.core.Transfer.transfer(Unknown Source)
         at ch.cyberduck.core.Transfer.start(Unknown Source)
         at ch.cyberduck.ui.cocoa.CDTransferController$3.run(Unknown
         at ch.cyberduck.ui.cocoa.CDWindowController$1.run(Unknown Source)

Ticket URL: <http://trac.cyberduck.ch/ticket/1160>
Cyberduck <http://cyberduck.ch>
FTP and SFTP Browser for Mac OS X.

More information about the Cyberduck-trac mailing list