[Cyberduck-trac] [Cyberduck] #3756: S3 read failure

Cyberduck trac at trac.cyberduck.ch
Sun Sep 27 21:10:22 CEST 2009

#3756: S3 read failure
 Reporter:  Jim Schwartz <reg@…>            |       Owner:  dkocher
     Type:  defect                          |      Status:  new    
 Priority:  normal                          |   Milestone:         
Component:  s3                              |     Version:  3.2.1  
 Severity:  normal                          |    Keywords:         
 I created a new S3 account and did a couple of test uploads and download
 with Cyberduck 3.2.1. It worked as expected.

 Later, I uploaded a few folders and subfolders worth of data, maybe 1GB
 worth, to the account on Windows with CloudBerry Explorer. That worked and
 the listing on Cloudberry was as expected.

 Then, I opened Cyberduck to upload data from the Mac. That's where the
 surprises begin. My bucket and it's contained directories are present. But
 when I try to open those directories, I get errors in the form of a
 Failures dialog:

 The last action could not be completed due to the following errors:
 S3 Error:
 <s3 pathname displayed>
 Request Error.. Not Found.

 The transcript reads, in one particular case:

 x-amz-request-id: 82...<rest of id removed for security>[\r][\n]
 x-amz-id-2: eQV<rest of id removed for security>[\r][\n]
 Content-Type: application/xml[\r][\n]
 Transfer-Encoding: chunked[\r][\n]
 Date: Sun, 27 Sep 2009 19:05:00 GMT[\r][\n]
 Server: AmazonS3[\r][\n]

 If I then use CloudBerry on Windows or S3Hub on the Mac, I'm able to view
 the bucket and its contents as expected. Restarting Cyberduck doesn't
 change anything.

Ticket URL: <http://trac.cyberduck.ch/ticket/3756>
Cyberduck <http://cyberduck.ch>
FTP, SFTP, WebDAV, Cloud Files and Amazon S3 Browser for Mac OS X.

More information about the Cyberduck-trac mailing list