[Cyberduck-trac] [Cyberduck] #5586: UnsupportedClassVersionError

Cyberduck trac at trac.cyberduck.ch
Thu Dec 23 11:44:58 CET 2010

#5586: UnsupportedClassVersionError
    Reporter:  https://www.google.com/accounts/o8/id?id=aitoawmzjwsjlt1dqmrmsn6ss6yutv2n5wdixhw  |        Owner:               
        Type:  defect                                                                            |       Status:  reopened     
    Priority:  high                                                                              |    Milestone:               
   Component:  core                                                                              |      Version:  3.8.1        
    Severity:  normal                                                                            |   Resolution:               
    Keywords:  launch                                                                            |     Platform:  Mac OS X 10.6
Architecture:  Intel                                                                             |  

Comment (by jnd):

 Hi David, there seem to be two or three issues beneath the surface. Either
 way, I think it's a bug with Apple's Java Application Launcher. FYI, my
 JVM preferences were:

 Java 6 x86_64[[BR]]
 Java 5 x86_64[[BR]]
 Java 5 i386[[BR]]
 Java 4 i386

 All of them are Apple-supplied JVMs & JDKs. All of them work with Snow
 Leopard. (Although by default Apple, moves the pre-6 JVMs into a
 "disabled" folder or equivalent. I moved them out of the "disabled" folder
 because it was the easiest way to support legacy corporate software.)

 Firstly, I tried to find out what JVM my Mac was using to open Cyberduck.
 It was using Java 5. (I confirmed this by renaming my Java 5 runtime...and
 Cyberduck failed to launch because of "file not found". Then I restored my
 Java 5, and Cyberduck was once again affected by

 Secondly, I noticed that I was missing the 32-bit version of Java 6
 (i386). I manually inserted it into my Host-specific preferences. That is,
 I edited

 After editing my plist file, Cyberduck '''successfully launches''' with
 the Java 6 runtime. So my problem is solved.

 This leaves two puzzles: why didn't Cyberduck originally launch with the
 64-bit Java 6? and why was Java 5 not able to run the program? I can't
 solve either of these, but perhaps the original bug reporter should try
 editing his or her plist file?

Ticket URL: <http://trac.cyberduck.ch/ticket/5586#comment:8>
Cyberduck <http://cyberduck.ch>
Open source FTP, SFTP, WebDAV, Cloud Files, Google Docs & Amazon S3 Browser for Mac & Windows.

More information about the Cyberduck-trac mailing list