[Cyberduck-trac] [Cyberduck] #4213: directory links work in FTP, but not SFTP...

Cyberduck trac at trac.cyberduck.ch
Tue May 11 23:25:56 CEST 2010

#4213: directory links work in FTP, but not SFTP...
 Reporter:  mike.kristopeit@…               |       Owner:  dkocher
     Type:  defect                          |      Status:  new    
 Priority:  normal                          |   Milestone:         
Component:  sftp                            |     Version:  3.4.1  
 Severity:  normal                          |    Keywords:  links  

Comment(by GlowingApple):

 I don't know if I can shed any light on this, but I ran into this same

 For my particular example, I found that if the symlink was an absolute
 link (i.e. it linked to "/dir/dir2/dir3") Cyberduck saw it as a file and
 tried to download it (and subsequently failed).  I then noticed that other
 links were being followed properly, and they were all relative links.  So,
 once I changed the symlink to be a relative link (i.e. it now links to
 "../dir/dir2/dir3") Cyberduck follows it as if it were a regular

 Using the stock CLI sftp client, I was able to cd through the link in
 either case, but Cyberduck only followed it properly once it was relative.

Ticket URL: <http://trac.cyberduck.ch/ticket/4213#comment:9>
Cyberduck <http://cyberduck.ch>
FTP, SFTP, WebDAV, Cloud Files and Amazon S3 Browser for Mac OS X.

More information about the Cyberduck-trac mailing list