[Cyberduck-trac] [Cyberduck] #6598: Cannot delete files with S3 protocol (GreenQloud)

Cyberduck trac at trac.cyberduck.ch
Fri Mar 23 16:33:22 CET 2012

#6598: Cannot delete files with S3 protocol (GreenQloud)
    Reporter:  greenqloud  |      Owner:
        Type:  defect      |     Status:  new
    Priority:  high        |  Milestone:
   Component:  core        |    Version:  Nightly Build
    Severity:  blocker     |   Keywords:  delete,snapshot, 9483,mac
Architecture:  Intel       |   Platform:  Mac OS X 10.7
 It worked fine to delete files in 4.2.1 but is broken in the latest
 snapshot release (9483). I get a "forbidden" error message. The test I did
 was to upload a file with no special characters to a bucket with no
 special characters and then I tried deleting it again. I have a feeling
 the command is trying to delete the wrong path or something has changed in
 the delete method for S3 protocol in this release.

 POST /?delete HTTP/1.1
 Date: Fri, 23 Mar 2012 15:29:53 GMT
 Content-MD5: ygJzdhZmyIr1E/wSYW6dhA==
 Content-Type: text/plain
 Authorization: AWS
 Content-Length: 120
 Host: permissionstest.s.greenqloud.com:443
 Connection: Keep-Alive
 User-Agent: Cyberduck/4.2.1 (Mac OS X/10.7.3) (i386)
 Expect: 100-continue
 HTTP/1.1 403 Forbidden
 Date: Fri, 23 Mar 2012 15:29:50 GMT
 Server: RestServer/1.0
 Content-Length: 110
 Content-Type: application/xml
 Cache-Control: no-cache
 Connection: close

Ticket URL: <http://trac.cyberduck.ch/ticket/6598>
Cyberduck <http://cyberduck.ch>
Open source FTP, SFTP, WebDAV, Cloud Files, Google Docs & Amazon S3 Browser for Mac & Windows.

More information about the Cyberduck-trac mailing list