[Cyberduck-trac] [Cyberduck] #7641: Version 4.4.2 trashing files

Cyberduck trac at trac.cyberduck.io
Tue Nov 26 00:44:43 UTC 2013

#7641: Version 4.4.2 trashing files
    Reporter:  michael smith  |      Owner:
        Type:  defect         |     Status:  new
    Priority:  high           |  Milestone:
   Component:  core           |    Version:  4.4.2
    Severity:  critical       |   Keywords:  encoding
Architecture:  Intel          |   Platform:  Mac OS X 10.7
 In trying to move a web site from one server to another we discovered that
 some of the files were trashed once they got there.  We tracked it down to
 downloading under version 4.4.2.  I've attached one of the files that was
 getting trashed - both the original and the trashed version.  The end of
 the downloaded file is messed up with random bytes.  It could be something
 like a file encoding issue, but the files should be utf8 which is what
 'default' used.

 * The process was downloading from a linux server to a mac.  Then
 uploading to a new linux server.  But the file is corrupted on the initial
 download.  Also doing an Edit (which downloads the file to textmate) shows
 the file as corrupt.

 * The file is not actually corrupted on the server.  SSH in and cat the
 file shows it correctly.

 * It's not random.  The same files will trash the same exact way each time
 we download them.  Even if they are in different folders. So we suspect it
 has to do with the contents of the file or the order of the characters or
 the length of the files.  But we don't know.

 * These are text files.  PHP code and java.  But also we did see a .zip
 file got corrupted on download.  But not every zip.  Not every text file.
 About 10 in 200 files on my particular web site.

 * We tried from two different macs with two different versions of OS -
 downloading from the same server.  One mac is 10.7.5.  Don't know the
 other one version.  Both macs with cyberduck 4.4.2 trash those particular

 * Using either ForkLift or Cyberduck (13582) 4.4.1 the file downloads
 correctly with the same settings from that same server.

 * We also tried from two different linux servers.  Using 4.4.2 that file
 is always corrupt in the same way, coming down from either of my servers.
 The servers are both CENTOS 6.4 x86_64 standard but are located in
 different states and have different versions of OS.  One has webmin
 installed and one has cpanel installed.

Ticket URL: <https://trac.cyberduck.io/ticket/7641>
Cyberduck <http://cyberduck.io>
Libre FTP, SFTP, WebDAV, S3 & OpenStack Swift browser for Mac and Windows

More information about the Cyberduck-trac mailing list