[Cyberduck-trac] [Cyberduck] #8175: Fingerprint on SFTP differs from SSH

Cyberduck trac at trac.cyberduck.io
Thu Aug 14 12:06:01 UTC 2014

#8175: Fingerprint on SFTP differs from SSH
    Reporter:  matthijs zwinderman  |      Owner:  dkocher
        Type:  defect               |     Status:  new
    Priority:  normal               |  Milestone:
   Component:  sftp                 |    Version:  4.5.1
    Severity:  normal               |   Keywords:  ssh fingerprint
Architecture:  Intel                |   Platform:  Mac OS X 10.9
 When connecting to my server over a local connection I get a different
 fingerprint using Cyberduck than from the regular "SSH" or "SFTP" or "SCP"
 command in Terminal.

 The fingerprint I get from Cyberduck ends in :63, while the fingerprint
 from SSH ends in :66
 These two should not differ.

 Things I've tried:

 - I listed the fingerprints of all the keys on my server (with "ssh-keygen
 -lf"), even the ones that are not in use (DSA). None match Cyberduck's
 - I've used Wireshark to check that Cyberduck connects directly with the
 right server (both SSH and Cyberduck follow the same path)
 - Ive tried connecting through a router, still get the wrong fingerprint

 The only thing I can imagine is Cyberduck calculating the fingerprint in a
 different way than SSH.

Ticket URL: <https://trac.cyberduck.io/ticket/8175>
Cyberduck <http://cyberduck.io>
Libre FTP, SFTP, WebDAV, S3 & OpenStack Swift browser for Mac and Windows

More information about the Cyberduck-trac mailing list