[Cyberduck-trac] [Cyberduck] #8064: 404 error response when downloading file in placeholder folder

Cyberduck trac at trac.cyberduck.io
Tue Jul 22 11:50:56 UTC 2014

#8064: 404 error response when downloading file in placeholder folder
 Reporter:  paulnicklin  |         Owner:  dkocher
     Type:  defect       |        Status:  reopened
 Priority:  normal       |     Milestone:  4.5
Component:  openstack    |       Version:  4.4.5
 Severity:  normal       |    Resolution:
 Keywords:               |  Architecture:  Intel
 Platform:  Windows 7    |
Changes (by paulnicklin):

 * status:  closed => reopened
 * resolution:  fixed =>



 Many thanks for the speedy investigation, but it still doesn't work for

 Not sure what the differences are between your successful test and my
 failure - so here are some hopefully salient bits..

 I'm on the beta build 14906 - hopefully that includes revision 14866
 (snapshot is the same build number)

 Not sure if the placeholder folder is supposed to be shown in the main
 tree (it doesn't, it's just a flat view of all files), but on the
 transfers dialog  the URL us shown as clientfiles-4742/x.pdf, ie no

 I'm using / as the separator in my cloud files, and the files often begin
 with a leading / but am on Windows (you use path.DELIMETER i think - my
 java is rusty (>12 years ago)  so I don't remember if this is the defined
 platform value or fixed)

 My connection uses the Rackspace (UK) profile - but I get the same with
 Swift (Openstack) and Rackspace (US). I created a new bookmark in case
 there was a cached value.

 Turned on debug logging. the first ref to my file is this - there is no
 reference to the placeholder/path.. (may be irrelevant)
 2014-07-22 12:43:25,275 [Thread-0] DEBUG RegistryApplicationFinder -
 GetRegisteredDefaultApplication for filename Address proof xxxxx.pdf

 and when I start the transfer.. still no path.

 2014-07-22 12:43:25,987 [background-1] DEBUG
 ch.cyberduck.core.transfer.Queue - Add transfer Transfer{transferred=null,
 proof xxxxx.pdf'}, remote=Path{path='/container-nnnnnn/Address proof
 xxxx.pdf', type=[file]}}], state=stopped,
 hostname='lon.identity.api.rackspacecloud.com', port=443,

 ..and not surprisingly I get 404.

 Any further assistance let me know.


Ticket URL: <https://trac.cyberduck.io/ticket/8064#comment:5>
Cyberduck <http://cyberduck.io>
Libre FTP, SFTP, WebDAV, S3 & OpenStack Swift browser for Mac and Windows

More information about the Cyberduck-trac mailing list