[Cyberduck-trac] [Cyberduck] #7852: Uploading a folder on Mac stops when it reaches a symlink

Cyberduck trac at trac.cyberduck.io
Tue Mar 18 19:03:11 UTC 2014

#7852: Uploading a folder on Mac stops when it reaches a symlink
    Reporter:  tihomir   |      Owner:
        Type:  defect    |     Status:  new
    Priority:  high      |  Milestone:
   Component:  core      |    Version:  4.4.3
    Severity:  normal    |   Keywords:  mac, symlink, symbolic, upload,
Architecture:  Intel     |  folder, delete, remove
                         |   Platform:  Mac OS X 10.7
 I'm uploading a folder which contains a symbolic link. I'm expecting this
 link to be resolved and the actual file to be uploaded on the server.
 However the upload stops when it reaches the symlink and the rest of the
 files (and folders) are not uploaded.

 I'm uploading the folder by command-C in Finder and command-V in

 If I try to upload just the symlink this way it does not work. However if
 I upload using the "select file for upload" dialog (option-up) I'm able to
 upload just that file.

 I tried to delete the folder then and an empty placeholder remained
 (attached). I hit Refresh a few times. Nothing changed. I tried to upload
 the folder again (the same way — command-C, command-V) - nothing happened.
 Nothing has been uploaded. I restarted CyberDuck and I found the folder is
 there but again half-uploaded.

 Currently CyberDuck is practically unusable for such folders and I have to
 use another way of doing my job. Maybe downgrading to a lower version...?

 I'm using version 4.4.4 (just downloaded it).

Ticket URL: <https://trac.cyberduck.io/ticket/7852>
Cyberduck <http://cyberduck.io>
Libre FTP, SFTP, WebDAV, S3 & OpenStack Swift browser for Mac and Windows

More information about the Cyberduck-trac mailing list