[Cyberduck-trac] [Cyberduck] #8347: Field names are different between OSX and Windows versions

Cyberduck trac at trac.cyberduck.io
Fri Nov 21 01:33:06 UTC 2014

#8347: Field names are different between OSX and Windows versions
    Reporter:  kppaule  |      Owner:
        Type:  defect   |     Status:  new
    Priority:  normal   |  Milestone:
   Component:  core     |    Version:  4.6
    Severity:  normal   |   Keywords:
Architecture:           |   Platform:  Windows 7
 Hi there,

 I'm getting a "Connection Failed" error when trying to connect to our
 Rackspace Cloud files from Cyberduck on Windows 7 on my company's internal
 network (connected via Ethernet cable).  Rackspace tech support says its a
 problem on our network.  My company's IT department says its not a problem
 on the network since the firewall is allowing the IP's to connect.  I'm
 using the settings downloaded from here:

 I have however, been able to connect on that network using a Mac running
 OSX (Yosemite).  The settings I used there that worked used the Swift
 protocol, so I tried to replicate that on the Windows 7 computer.
 However, the field names in the Windows 7 version are different than on
 the Mac version.  When creating a bookmark, where it says "Username" on
 the Mac it says Tenant ID:Access Key: on Windows.  Then in the following
 screen, it asks for a "Secret Key".  To make things even more confusing,
 the Rackspace documentation doesn't mention any of those 3 terms in it's
 instructions here:

 In the Tenant ID: Access Key field, when I enter my rackspace username as
 the tenant ID and my API Key as the Access key separated by a colon like
 this "username:APIKey" I get an error: Interoperability failure".

 Any clarification would be appreciated.  I'm running out of hair to pull
 out of my head.


Ticket URL: <https://trac.cyberduck.io/ticket/8347>
Cyberduck <http://cyberduck.io>
Libre FTP, SFTP, WebDAV, S3 & OpenStack Swift browser for Mac and Windows

More information about the Cyberduck-trac mailing list