[Cyberduck-trac] [Cyberduck] #8732: #8597 Not completely fixed - "change of username or service not allowed"

Cyberduck trac at trac.cyberduck.io
Wed Apr 8 19:47:54 UTC 2015

#8732: #8597 Not completely fixed - "change of username or service not allowed"
    Reporter:  matthijs zwinderman  |      Owner:  dkocher
        Type:  defect               |     Status:  new
    Priority:  normal               |  Milestone:
   Component:  sftp                 |    Version:  4.6.5
    Severity:  major                |   Keywords:  ssh
Architecture:                       |   Platform:  Mac OS X 10.10
 After you fixed #8597, I could login for a little while on my SSH, it was
 flaky but it worked. Now I again get the same message:

 Change of username or service not allowed: (<<username>>,ssh-connection)
 -> (,ssh-connection). Please contact your web hosting service provider for

 I have private/public key + google authenticator. With the terminal-ssh on
 OSX this works fine, but not with Cyberduck.

 I fill in my username in the "open connection" dialog, check "use public
 key authentication". Click connect and then fill in the passphrase to the
 key (here the username is remembered). Clicking 'Login' again I now get a
 "partial authentication success" dialog, where the username is empty and I
 have to fill in a password (which is weird, since I don't get this for the
 I tried entering the verification code (from google authenticator), but it
 doesn't work.

 /// Since #8597 I've removed the need for password during login, now it's
 only key- and authenticator

Ticket URL: <https://trac.cyberduck.io/ticket/8732>
Cyberduck <https://cyberduck.io>
Libre FTP, SFTP, WebDAV, S3 & OpenStack Swift browser for Mac and Windows

More information about the Cyberduck-trac mailing list