[Cyberduck-trac] [Cyberduck] #10447: CLI duck stuck at version 0.12 on Raspberry Pi

Cyberduck trac at cyberduck.io
Sun Sep 2 23:45:47 UTC 2018

#10447: CLI duck stuck at version 0.12 on Raspberry Pi
 Reporter:  Sky_Paladin           |         Owner:
     Type:  defect                |        Status:  closed
 Priority:  normal                |     Milestone:
Component:  cli                   |       Version:  6.7.1
 Severity:  normal                |    Resolution:  worksforme
 Keywords:  Raspberry Pi, update  |  Architecture:
 Platform:                        |

Comment (by Sky_Paladin):

 Replying to [comment:3 dkocher]:
 > Can you confirm you added our repository to your package sources using
 > {{{
 > echo -e "deb https://s3.amazonaws.com/repo.deb.cyberduck.io stable main"
 | sudo tee /etc/apt/sources.list.d/cyberduck.list > /dev/null
 > }}}

 I can confirm.

 Echo to command line shows stable main was added to the cyberduck.list.d,
 although I did not do this - the installation instructions had me putting
 the stable main and the stable nightly in sources.list.d.  Opening up
 cyberduck.list shows that this line is the only contents of the file.

 I had actually commented the nightly and main builds from sources.list.d
 because when I ran
 {{{sudo apt-get install duck}}}

 I received warnings saying that these target packages:

 Are configured multiple times in /etc/apt/sources.list:6 and

 When I run {{{sudo apt-get install duck=}}} with the lines
 uncommented in /etc/apt/sources.list, there are no warnings - it simply
 fails with 'E: Version '' for 'duck' was not found}}}

Ticket URL: <https://trac.cyberduck.io/ticket/10447#comment:4>
Cyberduck <https://cyberduck.io>
Libre FTP, SFTP, WebDAV, S3 & OpenStack Swift browser for Mac and Windows

More information about the Cyberduck-trac mailing list