[Cyberduck-trac] [Cyberduck] #10792: difficulty uploading to a different region in Duck CLI

Cyberduck trac at cyberduck.io
Wed Sep 4 14:57:00 UTC 2019

#10792: difficulty uploading to a different region in Duck CLI
    Reporter:  MarkBlaise  |      Owner:
        Type:  defect      |     Status:  new
    Priority:  high        |  Milestone:
   Component:  cli         |    Version:  7.0.1
    Severity:  normal      |   Keywords:
Architecture:  Intel       |   Platform:  Windows 8.1
 Duck CLI version: Cyberduck 7.0.2 (30998). Registered to Mark Bax

 I've been using Duck CLI for about 8 months to upload data to Wasabi on
 region us-east-1. These commands have worked fine:

 for a listing:

 duck  -l  wasabisys://T5ZHIOV9VGMNBAKU1HQ4@Blaise-Backup/Magni/Diff/


 to upload a file:

 duck  -P --existing resume --parallel 32     --upload
 wasabisys://T5ZHIOV9VGMNBAKU1HQ4@Blaise-Backup/Magni/Diff/ <local file>


 I now need to upload files to the same wasabi account, but to the us-
 west-1 region. This command works to get a listing:

 duck     --region us-west-1 -l wasabisys://T5ZHIOV9VGMNBAKU1HQ4@blaise-


 but this upload command fails

 duck -P --existing resume --parallel 32    --region us-west-1 --upload
 wasabisys://T5ZHIOV9VGMNBAKU1HQ4@blaise-backup-west/Magni/Diff/  <local


 The error message I get is:

 Transfer incomplete. <local file>…
 Upload <local file> failed. The bucket you are attempting to access must
 be addressed using the specified endpoint. Please send all future requests
 to this endpoint. Please contact your web hosting service provider for


 what am I missing?

 FYI, I tried using the --profile parameter, but I can't seem to get that
 to work either ...

 Also, I have gotten the Cyberduck GUI to properly access both regions.


Ticket URL: <https://trac.cyberduck.io/ticket/10792>
Cyberduck <https://cyberduck.io>
Libre FTP, SFTP, WebDAV, S3 & OpenStack Swift browser for Mac and Windows

More information about the Cyberduck-trac mailing list