[Cyberduck-trac] [Cyberduck] #7310: Edited file not uploaded after save

Cyberduck trac at cyberduck.io
Fri Jun 19 13:22:18 UTC 2020

#7310: Edited file not uploaded after save
 Reporter:  timsk          |         Owner:  dkocher
     Type:  defect         |        Status:  closed
 Priority:  normal         |     Milestone:  8.0
Component:  core           |       Version:  7.4.0
 Severity:  normal         |    Resolution:  fixed
 Keywords:  editor upload  |  Architecture:  Intel
 Platform:  macOS 10.15    |
Changes (by TimAnthonyAlexander):

 * status:  reopened => closed
 * resolution:   => fixed


 I had this exact problem and fixed it:

 I use vim (Mac OS X 10.15) and with vim it would only upload the first
 I noticed that with other editors it worked fine. So I had to find the
 difference between these two editors.
 The main difference in saving files was that vim created a temporary file
 before saving (~filename.filetype). I disabled this (in vim with "set
 noswapfile", "set nobackup", "set nowritebackup"). After that, it worked
 perfectly fine! Hope this helps!

 Just try to find a way to disable these temporary files.

Ticket URL: <https://trac.cyberduck.io/ticket/7310#comment:6>
Cyberduck <https://cyberduck.io>
Libre FTP, SFTP, WebDAV, S3 & OpenStack Swift browser for Mac and Windows

More information about the Cyberduck-trac mailing list