[Cyberduck-trac] [Cyberduck] #11061: S3 HTTP profile is sending encrypted data after update to 7.4.0

Cyberduck trac at cyberduck.io
Thu May 28 19:53:32 UTC 2020

#11061: S3 HTTP profile is sending encrypted data after update to 7.4.0
    Reporter:  marcv   |      Owner:
        Type:  defect  |     Status:  new
    Priority:  normal  |  Milestone:
   Component:  s3      |    Version:  7.4.0
    Severity:  normal  |   Keywords:
Architecture:  Intel   |   Platform:
 I just updated to Cyberduck 7.4.0, and I tried to connect to an on-premise
 S3 storage system (Scality-based) that I used to use for testing. I got an
 error about a failed directory listing.
 "Failed to parse XML document with handler class
 Please contact your web hosting service provider for assistance."

 I looked at the logs on my Scality system and my endpoint was sending a
 "400 Bad request response back".I was using a non-SSL endpoint for this
 test, and the S3 HTTP cyberduckprofile downloadable on the Amazon S3
 protocol page.

 When I sniffed the network, I saw a request come in from my client machine
 where cyberduck is running, but it was all garbage. That's when i started
 suspecting that the request was coming in SSL-encrypted, on an endpoint
 configured to not use SSL.

 I tried the same cyberduck, and profile/access credentials on an SSL
 endpoint, and it worked.

 Can you please look into this?


Ticket URL: <https://trac.cyberduck.io/ticket/11061>
Cyberduck <https://cyberduck.io>
Libre FTP, SFTP, WebDAV, S3 & OpenStack Swift browser for Mac and Windows

More information about the Cyberduck-trac mailing list